Rowan-Salisbury Schools - Canvas Down Statewide – Incident details

Canvas Down Statewide

Resolved
Operational
Started about 3 years agoLasted about 3 hours

Affected

Classroom Softwares

Major outage from 2:21 PM to 5:00 PM

Canvas

Major outage from 2:21 PM to 5:00 PM

Updates
  • Resolved
    Resolved

    The state has resolved the authentication issues. Canvas should be up and running.

  • Monitoring
    Monitoring

    Users are receiving "Failure to Login" screens when they attempt to access Canvas. The state is aware, but no official updates have been sent out.